Legal Notice

The information in this publication is furnished for information use only, and does not constitute a commitment from NetWrix Corporation of any features or functions discussed. NetWrix Corporation assumes no responsibility or liability for the accuracy of the information presented, which is subject to change without notice.

NetWrix is a registered trademark of NetWrix Corporation. The NetWrix logo and all other NetWrix product or service names and slogans are registered trademarks or trademarks of NetWrix Corporation. Active Directory is a trademark of Microsoft Corporation. All other trademarks and registered trademarks are property of their respective owners.

Disclaimers

This document may contain information regarding the use and installation of non-NetWrix products. Please note that this information is provided as a courtesy to assist you. While NetWrix tries to ensure that this information accurately reflects the information provided by the supplier, please refer to the materials provided with any non-NetWrix product and contact the supplier for confirmation. NetWrix Corporation assumes no responsibility or liability for incorrect or incomplete information provided about non-NetWrix products.

© 2012 NetWrix Corporation.

All rights reserved.
Table of Contents

1. INTRODUCTION ............................................................................................................. 4
   1.1. Overview .................................................................................................................. 4
   1.2. How This Guide is Organized .................................................................................. 4

2. INSTALLING MICROSOFT SQL SERVER 2005 EXPRESS AND CONFIGURING REPORTING SERVICES ......................................................................................................................... 5
   2.1. System Requirements .............................................................................................. 5
       2.1.1. Hardware Requirements .................................................................................. 5
       2.1.2. Software Requirements .................................................................................. 5
   2.2. Configuring IIS ........................................................................................................ 6
       2.2.1. Configuring IIS on Windows 7/Windows Vista .................................................. 6
       2.2.2. Configuring IIS on Windows 2008 .................................................................. 6
   2.3. Installing SQL Server 2005 Express ........................................................................ 9
   2.4. Enabling Script Execution in IIS ............................................................................ 10

3. INSTALLING MICROSOFT SQL SERVER 2008 R2 EXPRESS AND CONFIGURING REPORTING SERVICES ......................................................................................................................... 12
   3.1. System Requirements ............................................................................................ 12
       3.1.1. Hardware Requirements ................................................................................ 12
       3.1.2. Software Requirements ................................................................................ 12
   3.2. Installing SQL Server 2008 R2 Express ................................................................. 13
   3.3. Verifying Reporting Services Installation .............................................................. 14

4. INSTALLING MICROSOFT SQL SERVER 2012 EXPRESS AND CONFIGURING REPORTING SERVICES ......................................................................................................................... 16
   4.1. System Requirements ............................................................................................ 16
       4.1.1. Hardware Requirements ................................................................................ 16
       4.1.2. Software Requirements ................................................................................ 16
   4.2. Installing SQL Server 2012 Express ........................................................................ 17
   4.3. Verifying Reporting Services Installation .............................................................. 18
1. INTRODUCTION

1.1. Overview

Microsoft SQL Server 2005/2008 R2/2012 Express with Advanced Services provides the Reporting Services platform that enables creating, viewing, and managing reports based on data stored in the local SQL Server Express instance. NetWrix products use Reporting Services to generate reports on events and changes in your IT infrastructure.

This article provides detailed instructions on how to install and configure different Microsoft SQL Server Express versions for Reporting Services to function properly. It lists product requirements, guides you through the installation process, and explains how to configure the target servers.

**Note:** This article only lists the configuration steps required for proper functioning of NetWrix products. For full details on SQL Server installation, please refer to Microsoft documentation.

This guide can be used by system integrators and network administrators.

1.2. How This Guide is Organized

This section explains how this guide is organized and provides a brief overview of each chapter.

- Chapter 1 Introduction: the current chapter. It explains the purpose of this document, defines its audience and explains its structure.
- Chapter 3 Installing Microsoft SQL Server 2008 R2 Express and Configuring Reporting Services provides instructions on how to install Microsoft SQL Server 2008 R2 Express and configure Reporting Services.
- Chapter 4 Installing Microsoft SQL Server 2012 Express and Configuring Reporting Services provides instructions on how to install Microsoft SQL Server 2012 Express and configure Reporting Services.
2. **INSTALLING MICROSOFT SQL SERVER 2005 EXPRESS AND CONFIGURING REPORTING SERVICES**

This section provides instructions on how to install Microsoft SQL Server 2005 Express on Windows 7/ Windows Vista and Windows 2008 and configure Reporting Services used by NetWrix products. Perform the following procedures in the order they are provided:

- **Configuring IIS**
  - Configuring IIS on Windows 7/Windows Vista
  - Configuring IIS on Windows 2008
- Installing SQL Server 2005 Express
- Enabling script execution for IIS

2.1. **System Requirements**

2.1.1. **Hardware Requirements**

Before installing MS SQL Server 2005 Express, make sure that your hardware meets the following requirements:

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>1 GHz or faster</td>
</tr>
<tr>
<td>Free hard-disk space</td>
<td>600 MB</td>
</tr>
<tr>
<td>RAM</td>
<td>Minimum 512 MB, recommended 1 GB or more</td>
</tr>
</tbody>
</table>

2.1.2. **Software Requirements**

For Reporting Services to operate normally, IIS 7.0 and .NET Framework 2.0 are required.
2.2. Configuring IIS

2.2.1. Configuring IIS on Windows 7/Windows Vista

Procedure 1. To configure IIS on Windows 7 / Windows Vista

1. Go to Start → Control Panel → Programs → Programs and Features → Turn Windows features on or off.

2. Make sure that Internet Information Services are configured as shown in the figure below:

   ![IIS Configuration](image)

   **Figure 1: IIS Configuration**

Procedure 2. To configure IIS on Windows 2008

1. Go to Start → Administrative Tools and launch the Server Manager snap-in.

2.2.2. Configuring IIS on Windows 2008
2. Select the Roles node and click Add Roles on the right:

   Figure 2: Server Manager

3. In the Add Roles Wizard, click Server Roles on the left, select Web Server IIS on the right, and click Next:

   Figure 3: Add Roles Wizard: Select Server Roles
4. On the next step, select **Role Services** under **Web Server (IIS)** and make sure the role services are configured as shown in the figures below:

**Figure 4:**  *Add Roles Wizard: Select Role Services*

![Add Roles Wizard: Select Role Services](image1)

**Figure 5:**  *Add Roles Wizard: Select Role Services (continued)*

![Add Roles Wizard: Select Role Services (continued)](image2)
2.3. Installing SQL Server 2005 Express

Microsoft SQL Server 2005 Express installation package can be downloaded at Microsoft Download Center.

Procedure 3. To install SQL Server 2005 Express on Windows 7 / Windows Vista or Windows 2008

1. Run the installation package and follow the instructions of the wizard until you get to the Registration Information page. On this page, clear the Hide advanced configuration options check box and click Next:
2. On the Feature Selection page, click the icon next to the Reporting Services node, and select the Entire feature will be installed on local hard drive option:

![Figure 8: Feature Selection Page](image)

3. Follow the instructions of the wizard to complete the installation.

2.4. Enabling Script Execution in IIS

To enable script execution in IIS on Windows 7 / Windows Vista or Windows 2008, perform the following procedure:

**Procedure 4. To enable script execution in IIS**

1. Go to Start → Run and launch the Microsoft Management Console by typing `mmc`.

2. Select Add/Remove Snap-in from the File menu. In the window that opens, select Internet Information Services from the Available snap-ins list and click the Add button. Then click OK:

![Figure 9: Add or Remove Snap-ins Dialog](image)
3. Select the **Internet Information Services (IIS) Manager** node and double-click **Handler Mappings** in the right pane:

   **Figure 10:** ReportServer$SQLExpress Home Page

4. On the **Handler Mappings** page, select ‘CGI-exe’ under **Disabled** and click **Edit Feature Permissions** in the **Actions** pane on the right:

   **Figure 11:** Handler Mappings

5. Select the **Script** and **Execute** options in the dialog box that opens and click **OK**:

   **Figure 12:** Edit Feature Permissions Dialog

6. Repeat the same operation for ‘ISAPI-dll’.

7. Restart IIS by executing the **IISRESET** command in the command prompt.
3. **Installing Microsoft SQL Server 2008 R2 Express and Configuring Reporting Services**

This section provides instructions on how to install Microsoft SQL Server 2008 R2 Express and configure the Reporting Services used by NetWrix products. Perform the following procedures in the order they are provided:

- **Installing SQL Server 2008 R2 Express**
- **Verifying Reporting Services Installation**

**Note:** These instructions are applicable to any Windows version.

### 3.1. System Requirements

#### 3.1.1. Hardware Requirements

Before installing MS SQL Server 2008 R2 Express, make sure that your hardware meets the following requirements:

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Minimum 1.4 GHz, recommended 2 GHz or faster</td>
</tr>
<tr>
<td>Free hard disk space</td>
<td>Minimum 2.2 GB</td>
</tr>
<tr>
<td>RAM</td>
<td>Minimum 512 MB; recommended 2 GB and more</td>
</tr>
</tbody>
</table>

#### 3.1.2. Software Requirements

Before installing MS SQL Server 2008 R2 Express, make sure that your software meets the following requirements:

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Framework</td>
<td>Microsoft .NET Framework 3.5 SP1</td>
</tr>
<tr>
<td>Additional Software</td>
<td>• Windows Installer 4.5</td>
</tr>
<tr>
<td></td>
<td>• Windows PowerShell 1.0</td>
</tr>
</tbody>
</table>
3.2. Installing SQL Server 2008 R2 Express

Microsoft SQL Server 2008 R2 Express installation package can be downloaded at Microsoft Download Center.

Procedure 5. To install SQL Server 2008 R2 Express

1. Run the installation package and follow the instructions of the wizard until you get to the Feature Selection page. On this page, ensure that the Reporting Services option is selected under Instance Features, and click Next:

   **Figure 13: Feature Selection Page**

   ![Feature Selection Page]

2. Proceed with the wizard until you get to the Server Configuration page. On this page, ensure that the SQL Server Reporting Services will run under the Network Service account, and its startup type is set to ‘Automatic’:

   **Figure 14: Server Configuration Page**

   ![Server Configuration Page]

3. Follow the instructions of the wizard to complete the installation.
3.3. Verifying Reporting Services Installation

As a rule, NetWrix products can use Reporting Services installed with the default settings. However, to ensure that Reporting Services are properly configured, it is recommended to perform the following procedure:

**Note:** You must be logged in as a member of the local administrators group on the computer where SQL Server 2008 R2 Express is installed.

**Procedure 6. To verify the Reporting Services installation**

1. Navigate to **Start → All Programs → Microsoft SQL Server 2008 R2 → Configuration Tools → Reporting Services Configuration Manager**.

2. In the **Reporting Services Configuration Connection dialog**, make sure that your local report server instance (for example **SQLExpress**) is selected and click **Connect**.

3. In the Reporting Services Configuration Manager left pane, select **Web Service URL**. The following page will be displayed:

   **Figure 15: Web Services URL Page**

4. On this page, make sure that the Virtual Directory parameter is set to ‘ReportServer_<YourSqlServerInstanceName>’ (‘ReportServer_SQLEXPRESS’ for the SQLExpress instance), and that the TCP Port is set to 80. Click **Apply**.

5. In the Reporting Services Configuration Manager left pane, select **Database**. The following page will be displayed:
6. On this page, ensure that the SQL Server Name and Database Name fields contain correct values. If not, click the Change Database button and complete the Report Server Database Configuration wizard.

7. In the Reporting Services Configuration Manager left pane, select Report Manager URL. The following page will be displayed:

   Figure 17: Report Manager URL Page

8. On this page, ensure that the Virtual Directory parameter is set correctly, and that the URL is valid.

9. Click Exit to close the Reporting Services Configuration Manager.
4. **Installing Microsoft SQL Server 2012 Express and Configuring Reporting Services**

This section provides instructions on how to install Microsoft SQL Server 2012 Express and configure the Reporting Services used by NetWrix products. Perform the following procedures in the order they are provided:

- [Installing SQL Server 2012 Express](#)
- [Verifying Reporting Services Installation](#)

4.1. System Requirements

4.1.1. Hardware Requirements

Before installing MS SQL Server 2012 Express, make sure that your hardware meets the following requirements:

**Table 4: Hardware Requirements**

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Minimum 1 GHz for x86 Processor / 1.4 GHz for x64 Processor, recommended 2 GHz or faster</td>
</tr>
<tr>
<td>Free hard-disk space</td>
<td>Minimum 6 GB</td>
</tr>
<tr>
<td>RAM</td>
<td>Minimum 512 MB; recommended 1 GB</td>
</tr>
</tbody>
</table>

4.1.2. Software Requirements

Before installing MS SQL Server 2012 Express, make sure that your software meets the following requirements:

**Table 5: Software Requirements**

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
</table>

**NOTE:** 32-bit and 64-bit platforms are supported

<table>
<thead>
<tr>
<th>Framework</th>
<th>Microsoft .NET Framework 3.5 SP1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Microsoft .NET Framework 4.0 is also required if you install SQL Server Express on a Server Core installation of Windows Server 2008 R2 SP1 or Windows Server 2012.</td>
</tr>
</tbody>
</table>

| Additional Software | • Internet Explorer 7 or later  
|                     | • Windows PowerShell 2.0 |
4.2. Installing SQL Server 2012 Express

Microsoft SQL Server 2012 Express installation package can be downloaded at Microsoft Download Center: select either ENU\x64\SQLEXPRESS\x64\ENU.exe or ENU\x86\SQLEXPRESS\x86\ENU.exe download packages.

Procedure 7. To install SQL Server 2012 Express

1. Run the installation package and follow the instructions of the wizard until you get to the Feature Selection page. On this page, ensure that the Reporting Services option is selected under Instance Features, and click Next:

   ![Feature Selection Page]

   Figure 18: Feature Selection Page

2. Proceed with the wizard until you get to the Server Configuration page. On this page, ensure that SQL Server Reporting Services will run under the Network Service account, and its startup type is set to ‘Automatic’:

   ![Server Configuration Page]

   Figure 19: Server Configuration Page
3. Follow the instructions of the wizard to complete the installation.

4.3. Verifying Reporting Services Installation

As a rule, NetWrix products can use Reporting Services installed with the default settings. However, to ensure that Reporting Services are properly configured, it is recommended to perform the following procedure:

**Note:** You must be logged in as a member of the local administrators group on the computer where SQL Server 2012 Express is installed.

Procedure 8. To verify the Reporting Services installation

1. Navigate to Start → All Programs → Microsoft SQL Server 2012 → Configuration Tools → Reporting Services Configuration Manager.

2. In the Reporting Services Configuration Connection dialog, make sure that your local report server instance (for example SQLExpress) is selected and click Connect.

3. In the Reporting Services Configuration Manager left pane, select Web Service URL. The following page will be displayed:

   ![Web Services URL Page](image)

4. On this page, make sure that the Virtual Directory parameter is set to ‘ReportServer_&lt;YourSqlServerInstanceName&gt;’ (‘ReportServer_SQLEXPRESS’ for the SQLEXPRESS instance), and that the TCP Port is set to 80. Click Apply.
5. In the Reporting Services Configuration Manager left pane, select Database. The following page will be displayed:

   **Figure 21: Database Page**

6. On this page, ensure that the SQL Server Name and Database Name fields contain correct values. If not, click the Change Database button and complete the Report Server Database Configuration wizard.

7. In the Reporting Services Configuration Manager left pane, select Report Manager URL. The following page will be displayed:

   **Figure 22: Report Manager URL Page**

8. On this page, ensure that the Virtual Directory parameter is set correctly, and that the URL is valid.

9. Click Exit to close the Reporting Services Configuration Manager.